Urgent! Update Whim to the latest version (1.2.1)

Please make sure you have the latest version of Whim installed to ensure full functionality of the service. You can do this in the AppStore. The latest update will also have improvements related to your journey results, as well as a totally new profile page. Have a nice Whim ride(s)! 

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.